The tracker device has been connected but is not working

Forum to report issues and bugs on Windows 7, 8, and 10.

The tracker device has been connected but is not working

Postby rachelmenzies » 04 Aug 2015, 19:19

I have an Eye Tribe (batch 2013-12) and am having problems with in on Windows 8.1 running in Parallels on Mac OS X. I have managed to get the SDK working on the Mac platform with no problems, but I need it to work in Windows so that I can use the Eye Proof Beta.

The error is: "The tracker device has been connected but is not working".

I've looked on previous posts and have checked the USB 3.0 drivers, which are fine. I've also tried re-installing the SDK, but no luck.

Has anyone had a similar issue, or have any further suggestions?
Posts: 1
Joined: 29 Jul 2015, 18:00

Re: The tracker device has been connected but is not working

Postby JeffKang » 05 Aug 2015, 02:14

Connected as USB 2, but not USB 3?
Another thing to check is the ports.
I downloaded USBDeview.
>USBDeview is a small utility that lists all USB devices that currently connected to your computer, as well as all USB devices that you previously used.
For each USB device, extended information is displayed: Device name/description, device type, serial number (for mass storage devices), the date/time device was added, VendorID, ProductID, and more...

I then tested the cheapest USB 3 device that I could find: a USB 3.0 Flash Drive.
Make sure that other USB 3 devices work, and that it's only the tracker that is mis-recognizing the port.

>"Connected but not working" and "must be connected to USB 3"
Posts: 129
Joined: 15 Feb 2014, 23:59

Re: The tracker device has been connected but is not working

Postby hugh.rabagliati » 07 Dec 2015, 15:30


I am also experiencing this problem. I have used the tracker on two different pcs and it has always worked fine. Only very occasionally needed a replug to connect.
After around 20 days of inactivity (stored in its box in my office) the tracker doesn't connect and the "device has been connected but is not working" error msg appears. Both pcs complain that the usb device is not recognized.

I am looking for a spare cable to try it with.
In the meantime I am wondering whether an update could fix this.
My version is 0.9.56

Thank you
Posts: 1
Joined: 27 Aug 2014, 14:33

Re: The tracker device has been connected but is not working

Postby Martin » 09 Dec 2015, 02:58

Hi Michela,

Sounds a bit odd, we have many devices laying around and I haven't seen any gone bad from just being in the box.

Has there been any other changes to the setup, such as updates, change of cables, usb hubs etc?

Which operating system are you using?

Testing with a different cable and/or USB port sounds like a good start. Also, if possible, please verify on a different computer. If the device is broken we will replace it.
Posts: 567
Joined: 29 Oct 2013, 15:20

Re: The tracker device has been connected but is not working

Postby t.brunobelli » 23 Sep 2016, 15:20

I´ve been having the same problem! The only change i had in my system is Windows 10. Also I started to use the "EyeTribe SDK for Windows v0.9.77". Please help me.
Posts: 2
Joined: 18 Apr 2014, 02:51

Re: The tracker device has been connected but is not working

Postby hektorka » 09 Nov 2016, 16:05

I have tested it again on the previously used Dell, but that time it has not on that laptop either.
Then I have received a firmware error message but since then I only receive the message that the device is unavailable.

According to USBdevView it is a device.

USB Devices List
Created by using USBDeview

Device Name Description Device Type Connected Safe To Unplug Disabled USB Hub Drive Letter Serial Number Created Date Last Plug/Unplug Date VendorID ProductID Firmware Revision USB Class USB SubClass USB Protocol Hub / Port Computer Name Vendor Name Product Name ParentId Prefix Service Name Service Description Driver Filename Device Class Device Mfg Power USB Version Driver Description Driver Version Driver InfSection Driver InfPath Instance ID Capabilities

TheEyeTribe USB Composite Device Unknown Yes Yes No No 0000000001 2016.11.09. 12:52:02 2016.09.09. 12:22:30 29ab 00fb 0.00 00 00 00 6&9289170&0 usbccgp @usb.inf,%GenericParent.SvcDesc%;Microsoft USB általános szülő-illesztőprogram usbccgp.sys (Szabványos USB állomásvezérlő) 500 mA 2.10 USB Composite Device 6.3.9600.17238 Composite.Dev.NT usb.inf USB\VID_29AB&PID_00FB\0000000001 Removable, UniqueID, SurpriseRemovalOK

Eyetribe log
2016-11-09 12:58:38.642|4256750894|I|Creating new log file
2016-11-09 12:58:38.642|4256750894|I|Initializing environment
2016-11-09 12:58:38.643|4256750894|I|Detecting primary screen
2016-11-09 12:58:38.644|4256750894|I|Register control handler
2016-11-09 12:58:38.644|4256750894|I|Default video system: Direct Show
2016-11-09 12:58:38.644|4256750894|I|Initializing config system
2016-11-09 12:58:38.645|4256750894|I|TCP port: 6555
2016-11-09 12:58:38.645|4256750894|I|Connections: local only
2016-11-09 12:58:38.645|4256750894|I|Framerate: 30
2016-11-09 12:58:38.656|4256750894|I|Initializing the Eye Tribe Server (v0.9.77)
2016-11-09 12:58:38.658|4256750894|I|Initializing network
2016-11-09 12:58:38.661|4256750894|I|Initializing dispatcher
2016-11-09 12:58:38.661|4256750894|I|Initializing Network
2016-11-09 12:58:38.661|4256750894|I|Setting network connection port
2016-11-09 12:58:38.661|4256750894|I|Setting max network connections
2016-11-09 12:58:38.661|4256750894|I|Starting Network
2016-11-09 12:58:38.661|4256750894|I|Checking for running instances
2016-11-09 12:58:38.663|4256750894|I|Creating Tracker Manager
2016-11-09 12:58:38.663|4256750894|I|Creating Camera Manager
2016-11-09 12:58:38.663|4256750894|I|Initializing COM library
2016-11-09 12:58:38.663|4256750894|I|Initialized COM library
2016-11-09 12:58:38.663|4256750894|I|Starting Device Monitor
2016-11-09 12:58:38.674|2309752702|I|Video capturing device Found: TheEyeTribe
2016-11-09 12:58:38.682|2309752702|I|Registering the device
2016-11-09 12:58:38.682|2309752702|I|Device registered
2016-11-09 12:58:38.682|2309752702|I|Video capturing device Found: Integrated Webcam
2016-11-09 12:58:38.683|2309752702|I|Registering the device
2016-11-09 12:58:38.683|2309752702|I|Device registered
2016-11-09 12:58:38.683|2309752702|I|Video capturing device Found: iSpy Virtual Devices
2016-11-09 12:58:38.683|2309752702|I|Ignoring the device
2016-11-09 12:58:38.683|2309752702|I|Validating camera device
2016-11-09 12:58:38.683|2309752702|I|Initializing tracker device
2016-11-09 12:58:38.683|2309752702|I|Starting Direct Show device
2016-11-09 12:58:38.695|2309752702|I|Building Direct Show render graph
2016-11-09 12:58:39.723|2309752702|E|Could not initialize The Eye Tribe Tracker
2016-11-09 12:58:39.728|2309752702|E|The tracker device has been connected but is not working
2016-11-09 12:58:39.733|4256750894|I|Creating Detection Manager
2016-11-09 12:58:39.751|4256750894|I|Creating Calibration Manager
2016-11-09 12:58:39.751|4256750894|I|Creating AutoExposureEstimator
2016-11-09 12:58:39.753|4256750894|I|Default calibration profile loaded!
2016-11-09 12:58:39.757|4256750894|I|Validating number of camera devices
2016-11-09 12:58:39.757|4256750894|I|Validating config chosen device
2016-11-09 12:58:47.943|4256750894|I|Shutting down Tracker Manager
2016-11-09 12:58:47.943|4256750894|I|Shutting down Camera Manager
2016-11-09 12:58:47.943|4256750894|I|Stopping Device Monitor
2016-11-09 12:58:48.732|4256750894|I|Uninitializing COM library
2016-11-09 12:58:48.732|4256750894|I|Uninitialized COM library
2016-11-09 12:58:48.732|4256750894|I|Shutting down Detection Manager
2016-11-09 12:58:48.732|4256750894|I|Shutting down Calibration Manager
2016-11-09 12:58:48.732|4256750894|I|Deinitializing dispatcher
2016-11-09 12:58:48.732|4256750894|I|Deinitializing Network Manager
2016-11-09 12:58:48.732|4256750894|I|Network Manager Deinitialized

I have read different topics but did not find the solution. I have seen that in some cases the questioners received answers in PM.

Please help me if you can.

Thank you for your help in advance.
Posts: 1
Joined: 09 Nov 2016, 16:02

Return to Issues and troubleshooting - Windows